Вопрос по информатике:
пожалуйста помогите очень надо!!!
В массиве храниться информация о стоимости товаров. Составьте программу, которая определяет стоимость самого дешевого(дорогого) товара и его индекс.
вот программа но в ней где-то ошибка
program xxx;
var a:array [1..10] of integer;
i, max, min:integer;
begin
for i:=1 to 10 do read(a[i]);
min:=1;
for i:=2 to 10 do
if a[i]<min then min:=a[i];
writeln('a[',i,']=',a[i]);
max:=a[i];
for i:=2 to 10 do
if a[i]>max then max:=a[i];
writeln('a[',i,']=',a[i]);
end.
- 12.11.2017 17:16
- Информатика
- remove_red_eye 2719
- thumb_up 63
Ответы и объяснения 2
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.