Вопрос по информатике:
С клавиатуры одной строкой вводят имя и фамилию. Составьте программу, которая определяет, есть ли во введенной строке заданный символ
- 17.08.2018 04:03
- Информатика
- remove_red_eye 5285
- thumb_up 82
Ответы и объяснения 1
var
slovo,simval:string;
i,k:integer;
begin
k:=0;
write('Введите имя и фамилию ');
readln(slovo);
write('Введите символ ');
readln(simval);
for i:=1 to length(slovo) do
begin
if slovo[i]=simval then k:=k+1;
if slovo[i]=simval then writeln(i,' ');
end;
if k>=1 then
writeln('Да, встречается ',k,' раз, на позиции ',i)else writeln('Нет');
end.
Я немножко перевыполнил) От показывает есть симаол или нет, если есть то сколько раз он входит и на какой позиции...
- 18.08.2018 18:33
- thumb_up 8
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.