Вопрос по информатике:
С клавиатуры вводят слово и символ. Составьте программу, которая: а) проверяет, есть ли в этом слове данный символ; б) определяет позицию заданного символа; в) подсчитывает колличество вхождений заданного символа.
- 23.12.2017 22:02
- Информатика
- remove_red_eye 2815
- thumb_up 43
Ответы и объяснения 1
var
slovo,simval:string;
i,k:integer;
begin
k:=0;
write('vvedite slovo ');
readln(slovo);
write('vvedite simval ');
readln(simval);
for i:=1 to length(slovo) do
begin
if slovo[i]=simval then k:=k+1;
if slovo[i]=simval then writeln(i,' ');
end;
if k>=1 then
writeln('YES vstre4aets9 ',k,' raz, na pozicii ',i)else writeln('NO');
writeln;
end.
вот в одном решении
- 25.12.2017 03:20
- thumb_up 31
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.