Вопрос по информатике:
С клавиатуры вводят слово и символ. Составьте программу, которая определяет позицию заданного символа.
- 27.11.2017 10:37
- Информатика
- remove_red_eye 13329
- thumb_up 88
Ответы и объяснения 2
паскаль:
uses crt;
var a,b:string;\ а-слово ,b-символ
i:integer;\ переменная для счета
begin
writeln ('Слово и символ');
readln (a,b);\\ввод данных
for i:=1to length(a) do if copy (a,i,1)=b then writeln (i);\\Копирование по порядку символов слова а и сравнение каждого с символом b. Вывод ответа. Или ответов
readkey;\\если символы в слове повторяются
end.
- 28.11.2017 16:09
- thumb_up 18
program xxx;
var a,s : string;
i:integer;
begin
writeln ('Введите слово и символ-');
readln (s,a);
for i:=1 to length(a) do
if copy (s,i,1)=a then writeln (i);
readln
end.
- 29.11.2017 12:43
- thumb_up 7
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.