Вопрос по информатике:
Помогите составить программу по информатике в Pascal ABC. Задание 1. С клавиатуры одной строковой вводят имя и фамилию. Составьте программу, которая: а) определяет, есть ли в определенной строке заданный символ; б) копирует в новую строку имя и выводит его; в) выводит сначала фамилию, а затем имя. Задание 2. Составьте программу, которая в строке "Касіу Ясь канюшыну" заменяет имя "Ясь" на "Янка". Задание 3. Составьте программу, которая в строке "реки горы и болота": а) удаляет слово "горы;б) Заменяет слово "болота" на "озера". Буду безмерно благодарна!!!
- 08.02.2016 22:09
- Информатика
- remove_red_eye 19750
- thumb_up 33
Ответы и объяснения 1
Задание 1
a)
program pr;
var
s:string;
c:char;
i:integer;
begin
writeln('Введите имя и фамилию в одной строке');
readln (s);
writeln('Введите заданный символ');
readln (c);
for i:=1 to length(s) do if s[i]=c then writeln ('В строке найден заданный символ');
readln;
end.
б)
program pr;
var
s,n:string;
c:char;
i:integer;
begin
writeln('Введите имя и фамилию в одной строке');
readln (s);
i:=1;
while s[i]' ' do i:=i+1;
n:=copy(s,1,i-1);
writeln(n);
readln;
end.
в)
program pr;
var
s,n,f:string;
c:char;
i:integer;
begin
writeln('Введите имя и фамилию в одной строке');
readln (s);
i:=1;
while s[i]' ' do i:=i+1;
n:=copy(s,1,i-1);
f:=copy(s,i+1,length(s)-i+1);
writeln(n);
writeln(f);
readln;
end.
Задание2
program pr;
var s:string;
begin
s:='Касіу Ясь канюшыну';
delete (s,7,3);
insert ('Ясь',s,7);
writeln (s);
readln;
end.
Задание 3
а)
program pr;
var
s:string;
begin
s:='реки горы и болота';
delete (s,6,5);{удаляем включая пробел}
writeln (s);
readln;
end.
б)
program pr;
var
s:string;
begin
s:='реки горы и болота';
delete(s,13,6);
s:=s+'озера';
writeln (s);
readln;
end.
;- 09.02.2016 01:48
- thumb_up 25
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.