Вопрос по информатике:
Из-за непогоды были отменены рейсы самолетов. Ненадолго проглянуло солнце: на N часов и M минут. Напишите программу, которая определяет, сколько самолетов успеет вылететь за это время, если на взлетной полосе может быть только один самолет, а интервал между взлетом двух самолетов- Z минут? Формат входных данных: С клавиатуры вводятся через пробел 3 числа: n, m, z, обозначающие часы и минуты, на которые проглянуло солнце и интервал между взлетом двух самолетов. Формат входных данных: На экран вывести количество успевших взлететь самолетов. Примеры входных и выходных данных: Ввод: Вывод: 1 12 33 2 1 15 25 3
- 08.09.2018 21:50
- Информатика
- remove_red_eye 17640
- thumb_up 82
Ответы и объяснения 1
Программа на языке pascal, успехов в учебе.
program pr;
var n,m,z,k,i,vm:integer;
begin
readln (n,m,z);
vm:=n*60+m;
i:=1;
while i<=vm do
begin
k:=k+1;
i:=i+z;
end;
writeln (k);
readln;
end.
- 09.09.2018 08:41
- thumb_up 24
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.