Вопрос по информатике:
Составьте программу, которая определяет, сколько слагаемых должно быть в сумме 1+2+3+4..., чтобы сумма оказалась: а)больше 20; б)больше заданного числа n.
- 12.08.2017 16:53
- Информатика
- remove_red_eye 3455
- thumb_up 54
Ответы и объяснения 1
нам это тоже задовали под буквой А я тож не знаю,а вот под буквой Б напишу
program prim;
var i,sum,n,x : integer;
begin
write('n = ');
readln(n);
x:=2;
sum:=2;
i:=1;
while sum<=n do
begin
x:=x+2;
i:=i+1;
sum:=sum+x;
end;
writeln(i,'слагаемых');
end.
- 13.08.2017 18:34
- thumb_up 32
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.