Вопрос по информатике:
. Составить программу, которая подсчитывает для каждого столбца массива А[1..5, 1..6] сумму значений элементов и формирует из полученных сумм одномерный массив B[1..6].
- 08.03.2018 11:07
- Информатика
- remove_red_eye 11152
- thumb_up 65
Ответы и объяснения 1
Программа на Паскале:
Program a1;
Var i, j : integer;
s : real;
a: array [1..5, 1..6] of real;
b: array [1..6] of real;
Begin
For i:=1 to 5 do
For j:=1 to 6 do
readln(a[i,j]);
For j:=1 to 6 do
Begin
s:=0;
For :=1 to 5 do
s:=s+a[i,j];
b[j]:=s
end;
Write ('Полученный массив В:');
For j:=1 to d do
write(b[j]);
readln
End.
- 08.03.2018 23:17
- thumb_up 18
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.