Вопрос по информатике:
составить программу, которая считает в формуле, заданной с клавиатуры, количество открывающихся и закрывающихся круглых скобок
- 05.01.2017 05:46
- Информатика
- remove_red_eye 15916
- thumb_up 69
Ответы и объяснения 1
Pascal:
program strings;
uses crt;
var i,open,close:integer;
a:String;
begin
open:=0;
end:=0;
clrscr;
write('Введите строку: '); readln(a);
for i:=1 to length(a) do
begin
if a[i]='(' then open:=open+1;
if a[i]=')' then close:=close+1;
end;
writeln('Открывающихся скобок: ', open, ' штук');
writeln('Закрывающихся скобок: ', close, ' штук');
readln;
end.
- 06.01.2017 18:01
- thumb_up 53
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.