Вопрос по информатике:
Идет К-ая секунда суток. Определите, сколько полных часов (H) и полных минут (М) прошло к этому моменту. (Например, если К=13257=3*3600+40*60+57, то H=3 и M=40)
Надо написать программу на основе PascalABC
Трудности с пониманием предмета? Готовишься к экзаменам, ОГЭ или ЕГЭ?
Воспользуйся формой подбора репетитора и занимайся онлайн. Пробный урок - бесплатно!
- 03.01.2015 07:35
- Информатика
- remove_red_eye 17267
- thumb_up 40
Ответы и объяснения 1
Begin
WriteLn('Введите номер секунды');
ReadLn(K);
H:=K div 3600;
M:=(K-H*3600) div 60;
K:=K-H*3600-M*60;
WriteLn('Прошло часов: ', H, '; минут: ', M, '; секунд: ', K);
Sleep(5000);
End.
- 04.01.2015 22:18
- thumb_up 27
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.