Вопрос по информатике:
Составьте программу которая формирует массив из 16 случайных чисел от -20 до 20 и:
а) находит элементы с нулевыми значениями
б) находит индексы четных элементов
в) подсчитывает количество отрицательных элементов
г) определяет, есть ли в этом массиве хотя бы одно число, кратное трем
д) находит в этом массиве индексы элементов, значения которых кратны трем .
На экран выводятся исходный массив и найденные элементы
Трудности с пониманием предмета? Готовишься к экзаменам, ОГЭ или ЕГЭ?
Воспользуйся формой подбора репетитора и занимайся онлайн. Пробный урок - бесплатно!
- 01.03.2015 16:58
- Информатика
- remove_red_eye 4174
- thumb_up 38
Ответы и объяснения 1
Const n=15;
Var a:array[1..n] of integer;
i,indx,k,tr,indxx:integer;
Begin
Randomize;
For i:=1 to n do begin
A[i]:=Random(40)-20;
Write(a[i],' ');
end;
Writeln;
write('0 имеет номер: ');
For i:=1 to n do
Begin
If A[i]=0 thenwrite(i);
end;
Writeln;
indx:=0;
For i:=1 to n do
Begin
If a[i] mod 2=0 then
begin
indx += 1;
a[indx]:=a[i];
end;
end;
Write('Индекс четных элементов: ');
For i:=1 to indx do
write(a[i],' ');
For i:=1 to n do
Begin
If A[i]<0 then
Begin
inc(k);
end;
end;
Writeln;
Writeln('Кoличество отрицательных элементов: ',k);
For i:=1 to n do
Begin
If A[i] mod 3=0 then
tr:=a[i];
end;
Writeln('Кратное трем ',tr);
indxx:=0;
writeln('Индексы кратны 3: ');
For i:=1 to n do
Begin
If a[i] mod 3=0 then
begin
indxx += 1;
a[indxx]:=a[i];
write(' ',a[i]);
end;
end;
end.
- 02.03.2015 08:19
- thumb_up 20
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.