Вопрос по информатике:
Напишите программу, которая проверяет, не приведет ли суммирование двух заданных целых чисел(Определенного типа) к переполнению.
- 22.06.2016 07:12
- Информатика
- remove_red_eye 18995
- thumb_up 45
Ответы и объяснения 1
Const
low=-32768;
high=32767;
Var i, j :integer;
begin
readln(i,j);
if sign(i)*sign(j)<0 then writeln('Сложение допустимо, результат ',i+j)
else
if i<0 then
if j
else
if j>high-i then writeln('Сложение недопустимо: возникнет переполнение')
else writeln('Сложение допустимо, результат ',i+j)
end.
- 23.06.2016 15:11
- thumb_up 36
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.