Вопрос по информатике:
Напишите программу, которая считывает с клавиатуры строку S и определяет, встречаются ли в строке S слова палиндромы. Словом считается последовательность символов, ограниченная проьелами, и не имеющая пробелов внутри себя. Строка S не пустая, содержит не более 200 символов и состоит только из строчных и прописных букв латинского алфавита и пробелов
Трудности с пониманием предмета? Готовишься к экзаменам, ОГЭ или ЕГЭ?
Воспользуйся формой подбора репетитора и занимайся онлайн. Пробный урок - бесплатно!
- 02.02.2015 18:25
- Информатика
- remove_red_eye 15354
- thumb_up 27
Ответы и объяснения 1
Var
s,t:string;
n,i:integer;
begin
write('Введите строку: ');
readln(t);
n:=1;
t:=t+' ';
for i:=2 to length(t) do
if ((t[i]=' ') or (i=length(t))) and (i-n>1) then
begin
s:=Copy(t,n,i-n);
if s=ReverseString(s) then
begin
writeln('Да, палиндромы есть');
halt
end
else n:=i+1
end;
writeln('Палиндромов нет')
end.
- 03.02.2015 21:39
- thumb_up 6
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.