Вопрос по информатике:
Написать программу вычисления произведений в Паскаль 2*4*6*...*(2n).
ПОМОГИТЕ ПЛИЗЗЗ решить срочно
- 15.03.2015 00:51
- Информатика
- remove_red_eye 11574
- thumb_up 12
Ответы и объяснения 2
через рекурсию
var
functionProduct(N: Integer): Integer;
begin
if N = 1then
begin
Product := 2;
Exit;
end;
Product := 2 * N * Product(N - 1);
end;
var
N: Integer;
begin
ReadLn(N);
WriteLn(Product(N));
ReadLn;
end.
без рекурсии
N, Y, I: Integer;
begin
ReadLn(N);Y := 1;I := 0;
repeat
Inc(I);
Y := Y * 2 * I;
until I = N;
WriteLn(Y);
ReadLn;
end.
- 16.03.2015 19:27
- thumb_up 1
var
N, Y, I: Integer;
begin
ReadLn(N); Y := 1; I := 0;
repeat
Inc(I);
Y := Y * 2 * I;
until I = N;
WriteLn(Y);
ReadLn;
end.
- 17.03.2015 16:50
- thumb_up 20
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.